Does pi comes for unbuntu


#1

Does pi canbe installed in ubuntu please say


#2

Send the same query to support@zerodha.com


#3

Hi,

Nope Its does not come for ubuntu or any other Linux based distribution.

But there is a work around for little pro users of UBUNTU (use Vine & configure manually).

I am not sure at this moment whether it will work or not. But I am going try this in coming weeks.

I will update my answer if I get any affirmative results.

Regards


#4

To install Zerodha Pi you need,

 1. Microsoft .NET Framework 4(x86 and x64)
 2. Microsoft Visual C++ 2008 Runtime Libraries(x86)
 3. Microsoft Visual C++ 2010 Runtime Libraries(x86)

__________________________________________________________________________

Step 1 :

First of all Install wine and winetricks.

wine using ppa for latest version

    sudo apt-add-repository ppa:ubuntu-wine/ppa
    sudo apt-get update
    sudo apt-get install wine1.7

winetricks as usual

    sudo apt-get install winetricks

________________________________________________________________________

Step 2 :

Most of the Windows apps work on 32 Bit. So you have to create a 32 Bit wineprefix by following commands,

    rm -fr ~/.wine  
    export WINEARCH="win32"
    export WINEPREFIX=~/.wine/

Now you can install Microsoft .NET Framework 4.0 using winetricks as,

    winetricks dotnet40

__________________________________________________________________________

Step 3 :

I suppose you have already downloaded Zerodha Pi from  Zerodha q-back office with the activation key. Extract pi.zip in the `Downloads` directory and you will get a directory pi. There you can find Pi_setup.exe. Run the following command to install it,

    wine ~/Downloads/pi/Pi_setup.exe

Before installing Pi you can see the system would install Microsoft Visual C++ 2008 and Microsoft Visual C++ 2010.

At last step Pi will be installed and a desktop icon will be created.  Just Log in with your credentials, answer those two security questions. Then Pi will ask for the activation key. Just put it to activate. Happy Trading.

_________________________________________________________________________

For more information please look at,

1.  Instaling Zerodha Trader or zerodha PI

2.  Running .Net 4.0 application with Wine

3.  How to install and configure Wine?


#5

Hi Ankur. Do you have any affirmative result? I tried with wine and PlayOnLinux but it does’nt work.


#6

I am receiving this error - http://pastebin.com/igvvxdBr after following these instructions.
Can someone help me
Thanks


#7

I too received similar error after following suggested setup steps, though wine version which I used was 1.8 and not 1.7 (which the example sights);
@ddas Are able to successfully use Pi on Ubuntu? which version?


#8

Sorry guys, :disappointed:. Its not working now. I struggled much to make this happen but failed. ‚ÄėWine‚Äô never worked for me as intended to do important things. And now, though unwillingly, I have to install windows to use PI. We may request @nithin to offer something like PI for Linux users because Linux is getting popular day by day.


#9

Any update on PI for Linux users?


#10

Well the installation went somoothly but when i try to run the program it gives me a error stating…
"Error invalid parameter"
and after i close the window i get another messege stating
"There is no windows program configured to open it properly"
any suggestions or help?

I am using lubuntu system on my netbook.


#11

Sorry @Mayank_Shukla, it’s not working. I switched to Kite.


#12

has anybody tried using pi using mono ? mono-project is specially developed for running dot net applications


#13

I have tried it to install … after many attempts … I am able to atleast start it and login.

But Its continously stuck with window ‚ÄúLoading Contracts for Subscribed Exchanges‚ÄĚ .

Whats change in my installation apart from above steps:

Install : winetricks dotnet46 and also install latest wine.

While installing, it asks whether its for all users of the machine or only you. I selected only me.

Looks like installation is successful and also I am able to login.